To learn about our efforts to improve the accessibility and usability of our website, please visit our Accessibility Information page. Skip to main content
Below is an advertisement.

MLB.com Franchise MVP Device Compatibility

Requires iOS 6.0 or later with the following iOS devices:
  • iPhone 4, 4S, 5, 5S, 5C
  • iPad 2, 3, 4, Air, Mini, Mini with Retina display
  • iPod Touch 5th gen
Requires Android OS 2.3.3 or later. North American devices tested:
  • Galaxy 9250
  • Samsung Nexus
  • ASUS Google Nexus 7
  • ASUS Nexus Tablet
  • ASUS - TF300
  • Samsung Google SA
  • Samsung Galaxy S
  • Samsung Galaxy SII
  • Samsung Galaxy SIII
  • Samsung Galaxy S4
  • Samsung Galaxy Tab 10.1
  • Samsung Galaxy Tab
  • HTC One S
  • Motorola Atrix
  • MZ600 Tablet